[RESOLVED]Visual Studio 2003 not showing web projects

I recently got a new PC and had all my development tools installed/configured, including Visual Studio 2003 (for support of older apps) and IIS.  When working on web projects in the past, I would open the project via File->Open->Project from Web.  The default
URL is http://localhost, as it was on my old PC.  When I click OK, no web projects are showing, even though I’ve setup a few asp.net web projects in IIS. 

To set these up, I moved the project to c:inetpubwwwroot<project name>, then go into IIS and change the folder to an app, and select 1.1 under the asp.net tab.  I’ve also made sure the Frontpage server extensions are installed.  I can open the project
by using File->Open->Project, but I get "Error while trying to run project: Unable to start debugging on the web server.  You do not have permissions to debug the server".  I found several articles online addressing this and have made all suggested changes
but so far nothing has worked.   I feel that if I can get the project to show/open as a web project it will resolve this issue as well.

Any help would be appreciated. 

hi…

     In web.config file authentication mode is there change the mode to windows try it.  

Thanks for the reply, but that did not work.  I tried this morning to create a new asp.net application and got the following error:

The web server reported the following error when attempting to create or open the Web project located at the following URL: "http://localhost/WebApplication1.’  ‘HTTP/1.1 500 Internal Server Error’

I am going to research a little this morning, and will reformat again if I cannot resolve.  I’ve been battling this for a week and need to move on. 

FYI, I found an article on adding .webinfo to the project and that got me to where I can open and work on the project.  Found out the webinfo file is not added to Visual Sourcesafe by default when you add the project through Visual Studio, which is what
I did.  I had to check it out when I got my new PC, but since this file was not included it just took recreating it to solve the problem.

I still am not able to open Web projects using File-Open-Project From Web, but as long as the webinfo file is in the same folder as my project I am able to work using File-Open-Project.

Leave a Reply