[RESOLVED]Video loads but doesn't play

We’ve upgraded our website from straight HTTP to MVC 5.  On it, we allow people to view various .swf videos.  We’ve been using swfobject.js with no issues.  However, when we switched to MVC, the video will load (you can see the correct time length) but will
not play.  All you have is a black screen.  Any ideas as to what could be preventing this from playing?  Is there something in MVC that is causing this?  When I view the HTML source that is rendered, everything looks the same.  Below is the view code:

<div>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="640" height="400" id="csSWF">
        <param name="movie" value="@VirtualPathUtility.ToAbsolute(Model.Path)" />
        <param name="play" value="true" />
        <param name="quality" value="best" />
        <param name="bgcolor" value="#1a1a1a" />
        <param name="allowfullscreen" value="true" />
        <param name="scale" value="showall" />
        <param name="allowscriptaccess" value="always" />
        <!–[if !IE]>–>
        <object type="application/x-shockwave-flash" data="@VirtualPathUtility.ToAbsolute(Model.Path)" width="640" height="400">
        <param name="play" value="true" />
        <param name="quality" value="best" />
        <param name="bgcolor" value="#1a1a1a" />
        <param name="allowfullscreen" value="true" />
        <param name="scale" value="showall" />
        <param name="allowscriptaccess" value="always" />
            <!–<![endif]–>
            <a href="http://www.adobe.com/go/getflashplayer">
                <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
            </a>
        <!–[if !IE]>–>
        </object>
        <!–<![endif]–>
    </object>
</div>

If you use the F12 developer tools in the browser you can check the console for any scripting errors. Also, you can use the Network tab to determine if there are any other issues such as a 404 for a script or resource.  THere shouldn’t be any difference
if it’s MVC or not since the end product gets to the browser ok, and it being processed on the browser. 

Does it happen with only particular clients? Certain browser versions?

Hi KSimmons,

As far as I know , please check this application at developer tools and whether there is any compatibility problems.

If  your question is still not resolved, please let me know.

Best regards,

Aswecan

Leave a Reply