[RESOLVED]troubleshooting type name issue – Twilio WebMatrix helper

Twilio just came out with an updated helper for WebMatrix, which I got installed and is now working correctly.

Unfortunately, I am still looking at the same error message in Visual Studio as I have been doing for the last 18 months:

"The type name "WebMatrix" does not exist in the type Twilio.WebMatrix.Twilio"

Every page where I use the direct:  @using Twilio.WebMatrix;   I get that same error message. Everything works.

Are there any additional troubleshooting steps I can take. Twilio does not care much to fix this, unless I start sending a gazillion SMS per day.

In my bin folder I have: Twilio.api.dll and Twilio.WebMatrix.dll.

Hi wavemaster,

Base on the Twilio.WebMatrix.xml file (in bin folder), we can found that there isn’t the
WebMatrix type in the Twilio.WebMatrix.Twilio type. I suggest that you could to check whether your code are correctly to use
Toilio WebMatrix helper.

On the other hand, you are using the third-party library, I suggest that you should post it to the
Twilio site.

Best Regards

Starain Chen

Hey wavemaster!  Twilio evangelist and maintainer of the .NET libraries here.  Our support team
filed an issue for this over on the C# libraries github page.  Would you mind  taking the conversation over there and I’m be happy to help.

Thanks!

Leave a Reply