[RESOLVED]Issue with flash file and Menu CSS

Hi here is my code…this is working good in fire fox but not in IE.

dropdown menu item do not show in IE..it comes beneath the flash file.

 <tr> <td><uc1:menu ID="menu2" runat="server" /></td></tr>
           <tr id="rowFlash" bgcolor="#FFCC00"><td>
           <object width="748px" height="140px" wmode="transparent"
classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://fpdownload.macromedia.com/
pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0">
<param name="SRC" value="mm.swf">
<embed src="mm.swf" width="748px" height="140px"></embed>
 <param name="wmode" value="transparent">
</object>
           
            
                        </td></tr>

Menu code is here

<asp:Menu DataSourceID="menuDataSource" Orientation="Horizontal" Width="100%"
        ID="lpMenu"
        runat="server"
       
        Font-Names="Verdana"
        Font-Size="X-Small"
        ForeColor="Black"
        StaticHoverStyle-ForeColor="black"
        StaticMenuItemStyle-ForeColor="#000000"
        StaticSelectedStyle-BackColor="#FF9900"
        BackColor="#FF9900"
        DynamicHorizontalOffset="3"
        StaticSubMenuIndent="15px">
        <levelsubmenustyles>
          <asp:submenustyle backcolor="#FF9900" />
          <asp:SubMenuStyle BackColor="#FF9900" />         
        </levelsubmenustyles>
            <StaticMenuItemStyle ForeColor="Maroon" BackColor="Transparent" Font-Names="Verdana" Font-Size="X-Small" CssClass="nav_item" />
            <StaticSelectedStyle BackColor="Yellow" CssClass="nav_item_active" ForeColor="black" />
            <StaticHoverStyle ForeColor="#FF9900" CssClass="nav_item_hover" />
            </asp:Menu>

 <asp:SiteMapDataSource runat="server" ID="menuDataSource" ShowStartingNode="false" />

<style type="text/css">
    .nav_item {
    color: #FF9900;
    background: url(images/n1.gif) repeat-y;
    background-position: top right;
    overflow: hidden;
    margin: 0;
    padding: 0;
    display: block;
    line-height: 12px;
    height: 18px;
    text-align: left;
    text-indent: 5px;
}

.nav_item_hover {
    color: black;
    background: url(/images/n1hover.gif) repeat-y;
    background-position: top right;
    overflow: hidden;
    margin: 0;
    padding: 0;
    display: block;
    line-height: 12px;
    height: 18px;
    text-align: left;
}

.nav_item_active {
    color: black;
    background: url(/images/n1hover.gif) repeat-y;
    background-position: top right;
    overflow: hidden;
    margin: 0;
    padding: 0;
    display: block;
    line-height: 12px;
    height: 18px;
    text-align: left;
}
</style>
any idea?

Hello,

Add style tag to the asp:Menu and set z-index value.

style="z-index:200"

And add style tag to your table and set it to a lower value than the value you set for the asp:Menu.

style="z-index:100"

i tried but not working

Hi, what’s your site address

Leave a Reply